Internal Server Error help, 500 error

Internal server errors can be caused by a few different things. Please check the Error Logs in cPanel for specific information.

Alternatively, here are the most common reasons for 500 errors:
(1) Bad permissions
Directories and folders should be 755. Executable scripts within the cgi-bin folder must be 755. Images, media, and text files like HTML should be 644.

(2) Bad .htaccess
In the (dot) htaccess file, you may have added lines that are either worded badly or conflicting. The best way to troubleshoot this is comment out the lines in the htaccess.
You can comment out a line in the .htaccess by adding # to the beginning. You are wise to save an original copy of any file before you make changes.
For example, if the .htaccess looks like 
DirectoryIndex default.html
AddType application/x-httpd-php5 php 
Then try something like this 
DirectoryIndex default.html
#AddType application/x-httpd-php5 php 
Broken lines and lines that start with php_flag are the most common mistakes. If you cannot determine which line is the problem, then comment out every line.

(3) Exceeding resources
It is possible your 500 error is caused by too many processes in the server queue.

Our server administrators will be able to advise you how to avoid this error. Please send email to support@hdwebprovider.net along with the steps needed to see the error.

  • Email, SSL
  • 11000 Users Found This Useful
Was this answer helpful?

Related Articles

Accessing Web Disk

Web disk (also known as Web Dav) is a drag-and-drop interface which allows you to access your...

Apache Error Logs

When you check the error logs, you can see many things.Some things you can ignore:File does not...

Apache modules that are on all of our shared servers

core.c mod_authn_file.c mod_authn_dbm.c mod_authn_dbd.c mod_authn_default.c mod_authn_alias.c...

Can I password protect directories?

To password protect directory: Wait! Why read this when you can watch the movie tutorial...

CGI center

The following CGI Scripts are pre-installed and ready to use on your account: Simple CGI Wrapper...